[Nagiosplug-help] Nagios - Problem with Webinject

alexandre fedi alex94130 at hotmail.fr
Fri Sep 17 13:30:11 UTC 2010


Hi,

I've got a problem with "Webinject" Addon for Nagios.

So, i just want to test authentication on an intranet application.

I configured everything correctly, and when I run the following command : "./webinject.pl -c config-myapplication.xml testmyapplication.xml", the result is following :

WebInject OK - All tests passed successfully in 1.368 seconds |time=1.368;20;;0

Everything seems to be OK, but, when I configure the same test in Nagios, I have this result on the web interface : (Return code of 13 is out of bounds) 

In nagios.log : [1284730251] Warning: Return code of 13 for check of service 'HTTP_SCENARIO' on host 'sp09400001' was out of bounds.

My commands file :

define command {
    command_name    check_webinject
    command_line    /usr/local/nagios/libexec/contrib/webinject/webinject.pl -c $ARG1$ $ARG2$
}

My service definition :

define service{
        use                             generic-service
        host_name                       sp09400001
        service_description             HTTP_SCENARIO
        check_command                   check_webinject!config-myapplication.xml!testmyapplication.xml
        }

Can somebody help me please ?

Thanks per Advance

Alexandre

 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nagios.com/pipermail/nagiosplugin-help/attachments/20100917/8fdc39b8/attachment.html>


More information about the Nagiosplugin-help mailing list