[Nagiosplug-help] checking logs

Robert Cole robert.cole at support4linux.com
Mon Jun 25 20:03:48 UTC 2007


Ok, I'm going nuts here because no matter what check log type of script 
I use on nagiosexchange.org none seem to work. I just tried 
check_logs.pl and that's even listed in the nagios book I have with an 
example yet I get this when I try to run it:

[root at tui001 ~]# /usr/lib64/nagios/plugins/check_logs.pl -c 
/etc/nagios/check_logs.cfg
Error: can not load configuration file.
[root at tui001 ~]#

The configuration file looks like this:

# /etc/nagios/check_logs.cfg
$seek_file_template='/home/nagios/$log_file.check_log.seek

@log_files = (
        {'file_name' => '/var/log/youmail/login.log',
         'reg_exp' => 'No ManagedConnections available within configured 
blocking timeout',
        },
);

I use to have a 1; down at the bottom using an example right out of the 
book "Nagios System and Network Monitoring" by Wolfgang Barth on page 
143 but it still didn't work and I got the same error there. The 
permissions on the file I even set to 777 so its not permissions.

Can anyone help me please? All I'm trying to do is look for specific 
strings of text in various log files and NOTHING I've found works. I've 
tried these plugins on Gentoo, RHEL v5, Fedora 7, CentOS 5 and nothing 
is working to simply look for strings of text. I'm not a scripter by any 
stretch and I have nagios working pretty well for anything that I can 
test from a remote station but getting anything that looks for strings 
of text via check_by_ssh or nrpe is a complete no go.

Please help.

Thanks,
Robert




More information about the Nagiosplugin-help mailing list