[Nagiosplug-help] nagios-plugin-1.4 'make' problem (long)

bru1n at comcast.net bru1n at comcast.net
Tue Apr 12 07:41:20 UTC 2005


root @ miata: uname -a
SunOS miata 5.10 Generic sun4u sparc SUNW,Sun-Fire-V210


I've compiled and installed nagios-2.0b3 using mostly defaults,
user/group=nagios, path=/usr/local/nagios, etc... I was following along the
docs (sourceforge version - apache/nagios main html is running with cgi
auth) and got to the nagios.cfg portion. As I was deciding to use
minimum.cfg or breaking out into hosts.cfg/hostgroups.cfg/etc, I saw the
section for check_*, and went looking for them. They weren't there so I went
and got the nagios-plugins-1.4.tar.gz (from several sources actually - after
the first didn't 'make'). Maybe someone here can make more sense of this..
looks like some library is giving me a headache .. I'm not sure how to go
about fixing it.

Note: The docs point to /usr/local/nagios/cgi-bin, however the 2.0b3 seems
to want to put then in /usr/local/nagios/sbin. No big worry, just a heads up
- please confirm. Here's my configure parms:

./configure --prefix=/usr/local/nagios --with-nagios-user=nagios
--with-nagios-group=nagios --with-cgiurl=/usr/local/nagios/sbin
--with-ipv6=no --with-ping6-command=no

I specifically turned off ipv6 -- it caused the configure script to take
longer while it looked for the ipv6 command string, and I know I'm not using
ipv6 anywhere. It didn't make a difference in the 'make', so I left it in.

Configure does its thing -- I didn't see any configure errors, except for
the missing modules for mysql, ldap, etc (documented in REQUIREMENTS), which
is fine, and should not cause my make problem.

Here's the last few lines of configure:
configure: creating ./config.status
config.status: creating Makefile
config.status: creating lib/Makefile
config.status: creating m4/Makefile
config.status: creating plugins/Makefile
config.status: creating plugins-scripts/Makefile
config.status: creating plugins-scripts/subst
config.status: creating plugins-scripts/utils.pm
config.status: creating plugins-scripts/utils.sh
config.status: creating command.cfg
config.status: creating test.pl
config.status: creating pkg/solaris/pkginfo
config.status: creating intl/Makefile
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing default-1 commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
                     --with-cgiurl: /usr/local/nagios/sbin
                --with-nagios-user: nagios
               --with-nagios-group: nagios
               --with-trusted-path: /bin:/sbin:/usr/bin:/usr/sbin
               --with-ping-command: /usr/sbin/ping -n -s %s 56 %d
              --with-ping6-command: no
                      --with-lwres: no
                       --with-ipv6: no
                    --with-openssl: no
      --enable-emulate-getaddrinfo: no

So then we 'make'. And all goes south.

root @ miata: make
make  all-recursive
Making all in intl
gcc -c -DLOCALEDIR=\"/usr/localblah blah blah blah .. no errors until

  -g -O2  -L. -o check_icmp  check_icmp.o  ../intl/libintl.a  -lgen -lsocket
Undefined                       first referenced
 symbol                             in file
gethostbyname                       check_icmp.o  (symbol belongs to
implicit dependency /usr/lib/libnsl.so.1)
inet_addr                           check_icmp.o  (symbol belongs to
implicit dependency /usr/lib/libnsl.so.1)
inet_ntoa                           check_icmp.o  (symbol belongs to
implicit dependency /usr/lib/libnsl.so.1)
ld: fatal: Symbol referencing errors. No output written to check_icmp
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `check_icmp'
Current working directory /tmp/nagios-plugins-1.4/plugins
*** Error code 1
The following command caused the error:
set fnord $MAKEFLAGS; amf=$2; \
dot_seen=no; \
target=`echo all-recursive | sed s/-recursive//`; \
list='intl lib plugins plugins-scripts m4 po'; for subdir in $list; do \
  echo "Making $target in $subdir"; \
  if test "$subdir" = "."; then \
    dot_seen=yes; \
    local_target="$target-am"; \
  else \
    local_target="$target"; \
  fi; \
  (cd $subdir && make  $local_target) \
   || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
done; \
if test "$dot_seen" = "no"; then \
  make  "$target-am" || exit 1; \
fi; test -z "$fail"
make: Fatal error: Command failed for target `all-recursive'
Current working directory /tmp/nagios-plugins-1.4
*** Error code 1
make: Fatal error: Command failed for target `all'


I googled the error and found this, which was similar, but its beyond me to
fix it I think..
http://sunportal.sunmanagers.org/pipermail/summaries/2002-February/000941.ht
ml

On a side note: There is a pkg directory which seems to accept pkgadd -d,
however the pkgmap file is missing (grumble). I did not try the CVS method.
Any assistance, or direction is appreciated. Hopefully I've done my
homework, and took the right steps to try and fix it, but it seems I'm
either overlooking something really dumb, or just not looking in the right
place. Apologies for the huge mail.

-Marc




More information about the Nagiosplugin-help mailing list