[Nagiosplug-help] NSCLIENT - Monitoring a service with space character in its real name

Luis Noronha luis.noronha at oni.pt
Wed Apr 6 15:24:04 UTC 2005

Sorry, man. Didn't work totally. I believe the service real name (in registry) is what's used by "net stop/start" and NSCLIENT.
Could someone contribute on this?
Luis Noronha


From: Tony Heal [mailto:theal at pace2020.com] 
Sent: Wednesday, April 06, 2005 4:02 PM
To: Luis Noronha; nagiosplug-help at lists.sourceforge.net
Cc: 'OniTelecom - Security NET4B'
Subject: RE: [Nagiosplug-help] NSCLIENT - Monitoring a service with space character in its real name

Have you tried changing the 'Display' name in services. If this is a Win2k or higher you can do this by right clicking the service, select properties and change the Display name. Not sure if this will work, but the command line 'net stop' and 'net start' will use the display name and that should only affect what is seen in services.msc, not what your program sees.

	-----Original Message-----
	From: nagiosplug-help-admin at lists.sourceforge.net [mailto:nagiosplug-help-admin at lists.sourceforge.net]On Behalf Of Luis Noronha
	Sent: Wednesday, April 06, 2005 10:33 AM
	To: nagiosplug-help at lists.sourceforge.net
	Cc: OniTelecom - Security NET4B
	Subject: [Nagiosplug-help] NSCLIENT - Monitoring a service with space character in its real name
	We're having trouble using "check_nt" (NSCLIENT plug-in) to monitor services that have a space character in its name (e.g. "Service ABC").
	I read the following post   http://sourceforge.net/mailarchive/message.php?msg_id=8135478

	, and looking at the registry (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services) one of the services really didn't have a space in its real name, and it solved the problem for this particular service :)


	Still, there is another service that has a space in its real name, therefore it still doesn't work: check_nt_service can't monitor it. (This is a commercial application and we can't modify its code/installation...)

	Changing the service real name in the registry causes the service to stop responding to stop/start commands.


	I also couldn't find any more posts on this subject in the archives :(
	I know this is an old issue, but can anyone provide further help on this?
	Is there a way around the problem or do we have to require real service names with no spaces?
	PS: I also have a problem with a service with an hyphen '-' in its real name...
	Best Regards,
	Luís Noronha

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nagios.com/pipermail/nagiosplugin-help/attachments/20050406/f5b3b309/attachment.html>

More information about the Nagiosplugin-help mailing list