[Nagiosplug-devel] [ nagiosplug-Bugs-2136116 ] make failure on solaris 9

SourceForge.net noreply at sourceforge.net
Tue Sep 30 22:35:07 UTC 2008

Bugs item #2136116, was opened at 2008-09-29 16:20
Message generated for change (Settings changed) made by tao71
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Compilation
Group: None
>Status: Closed
>Resolution: Fixed
Priority: 5
Private: No
Submitted By: tao71 (tao71)
Assigned to: Nobody/Anonymous (nobody)
Summary: make failure on solaris 9

Initial Comment:
I'm trying to compile nagios-plugins-1.4.13.
configure is fine, but make fails:

check_http.c:64: error: syntax error before '*' token
check_http.c:64: warning: data definition has no type or storage class
make[2]: *** [check_http.o] Error 1
make[2]: Leaving directory `/export/home/nagios/nagios-plugins-1.4.13/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/nagios/nagios-plugins-1.4.13'
make: *** [all] Error 2

I read through all bug reports and found a lot of hints, but none of them worked for me.
Even with the latest make (3.81), gcc (3.4.6) and libiconv (1.11) downloaded from sunfreeware didn't help.
I also tried with different versions of plugins (1.4.12 and 1.4.13), but I get the same errors.
And because I read in one of the closed bugs, to use solaris make, I tried it with /usr/local/bin at the beginning of PATH and in the end. But even this didn't make any change.

As I don't have a lot of experience with compiling, I'm stuck and need help. (On Linux it all worked fine, but not on Solaris...)

Please tell me if you need any additional information.

Thanks in advance.


Comment By: tao71 (tao71)
Date: 2008-10-01 00:33

Hi Thomas,
Thank you very much for your fast reply.
You were right, it was the OpenSSL installation which caused the problems.
The version we had on our machine must have been very weak, because there
were also links to some libraries missing.
In the end I fixed it by getting the latest package from
Configure and make were fine afterwards.
Thanks for your support.


Comment By: Thomas Guyot (dermoth)
Date: 2008-09-30 06:43

You seem to have a broken SSL installation (missing header files). You can

1. Configure without ssl support (no https, SSL, certificate or TLS

./configure --without-openssl

2. Fix/install openssl. According to your config.log it looks like it's
using /usr/local/ssl as your openssl installation.


You can respond by visiting: 

More information about the Nagiosplugin-devel mailing list