[Nagios-users] check_openmanage plugin reporting Firmware out of date

Trond Hasle Amundsen t.h.amundsen at usit.uio.no
Wed Dec 1 16:08:11 UTC 2010


"Surangiwala, Asif " <Asif.Surangiwala at firstdata.com> writes:

> I have Dell Open Manage Server Administrator 6.3.0 installed on some Dell
> R710’s with PERC H700 controller. When I run the Nagios plugin
> check_openmanage, it reports the following:
>
> Controller 0 [PERC H700 Integrated]: Firmware '12.10.0-0025' is out of date
>
> The H700 is running the latest firmware 12.10.0-0025, check_openmanage plugin
> is v3.6.2 by Trond H. Amundsen. OMSA is running fine and is not complaining
> about any firmware issues.
>
> The same ‘Firmware out of date’ warning is also given for H800 controllers on
> the R710’s having it.
>
> Is there an issue with the plugin’s interaction with OMSA?

Hi Asif,

This is a bug in OMSA, not check_openmanage. OMSA is reporting that the
firmware is too old while clearly it is not. Dell has stated that the
bug will be fixed in the next version of OMSA. For more information, see
the following thread on the Linux-Poweredge mailing list:

  http://lists.us.dell.com/pipermail/linux-poweredge/2010-December/043713.html

As a workaround, I suggest using blacklisting to suppress the false
warnings until OMSA 6.4.0 is released and deployed on your systems:

  check_openmanage -b ctrl_fw=all [..other options..]

Regards,
-- 
Trond H. Amundsen <t.h.amundsen at usit.uio.no>
Center for Information Technology Services, University of Oslo




More information about the Nagios-users mailing list